[ruby-de] data_frame error

Die Optimisten inform at die-optimisten.net
Di Mai 2 06:15:47 JST 2017


Hallo,

ich versuchte  require 'data_frame',
und erhalte schließlich

NoMethodError: undefined method `after_taint' for TransposableArray:Class
from 
.gem/ruby/2.4.0/gems/data_frame-0.1.8/lib/data_frame/transposable_array.rb:5:in 
`<class:TransposableArray>'
---

Datei transposable_array.rb:
class TransposableArray < CallbackArray ... end

Datei callback_array.rb:
class CallbackArray < Array
   include ActiveSupport::Callbacks
   define_callbacks :before_taint, :after_taint, :before_untaint, 
:after_untaint
...
end

Daher sollte after_taint doch verfügbar sein?!

Kann nur der Autor das gem updaten?

Gibts bessere gems mit solcher Funktion?


danke
Andreas



Mehr Informationen über die Mailingliste ruby-de