[ruby-cvs:71909] nobu:r64817 (trunk): kernel_warn.rb: skip kernel_require.rb

nobu at ruby-lang.org nobu at ruby-lang.org
Mon Sep 24 12:14:44 JST 2018


nobu	2018-09-24 12:14:43 +0900 (Mon, 24 Sep 2018)

  New Revision: 64817

  https://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=64817

  Log:
    kernel_warn.rb: skip kernel_require.rb
    
    * lib/rubygems/core_ext/kernel_warn.rb (Kernel#warn): skip
      kernel_require.rb's frames when `uplevel` option is given.

  Added files:
    trunk/lib/rubygems/core_ext/kernel_warn.rb
  Modified files:
    trunk/lib/rubygems.rb
    trunk/test/rubygems/test_require.rb


More information about the ruby-cvs mailing list