[ruby-cvs:72700] mame:r65600 (trunk): Rename get/setinlinecache to opt_get/opt_setinlinecache

mame at ruby-lang.org mame at ruby-lang.org
Wed Nov 7 17:13:20 JST 2018


mame	2018-11-07 17:13:20 +0900 (Wed, 07 Nov 2018)

  New Revision: 65600

  https://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=65600

  Log:
    Rename get/setinlinecache to opt_get/opt_setinlinecache
    
    The instructions are just for optimization.  To clarity the intention,
    this change adds the prefix "opt_", like "opt_case_dispatch".

  Modified files:
    trunk/compile.c
    trunk/insns.def
    trunk/test/ruby/test_jit.rb


More information about the ruby-cvs mailing list