[ruby-cvs:71169] mame:r64078 (trunk): eval.c: rename "rb_frozen_class_p" to "rb_class_modify_check"

mame at ruby-lang.org mame at ruby-lang.org
Fri Jul 27 22:57:15 JST 2018


mame	2018-07-27 22:57:14 +0900 (Fri, 27 Jul 2018)

  New Revision: 64078

  https://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=64078

  Log:
    eval.c: rename "rb_frozen_class_p" to "rb_class_modify_check"
    
    Just refactoring.  Despite its name, the function does NOT return a
    boolean but raises an exception when the class given is frozen.
    I don't think the new name "rb_class_modify_check" is the best, but
    it follows the precedeint "rb_ary_modify_check", and is definitely
    better than "*_p".

  Modified files:
    trunk/class.c
    trunk/eval.c
    trunk/include/ruby/backward.h
    trunk/include/ruby/intern.h
    trunk/internal.h
    trunk/variable.c
    trunk/vm_method.c


More information about the ruby-cvs mailing list