[ruby-cvs:68902] mame:r61721 (trunk): Rename code_range to code_location

mame at ruby-lang.org mame at ruby-lang.org
Tue Jan 9 17:45:35 JST 2018


mame	2018-01-09 17:45:35 +0900 (Tue, 09 Jan 2018)

  New Revision: 61721

  https://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=61721

  Log:
    Rename code_range to code_location
    
    Because the name "code_range" is ambiguous with encoding's.
    Abbreviations ("crange", and "cr") are also renamed to "loc".
    
    The traditional "code_location" (a pair of lineno and column) is
    renamed to "code_position".  Abbreviations are also renamed
    (first_loc to beg_pos, and last_loc to end_pos).

  Modified files:
    trunk/compile.c
    trunk/iseq.c
    trunk/iseq.h
    trunk/node.c
    trunk/node.h
    trunk/parse.y
    trunk/thread.c
    trunk/vm_core.h


More information about the ruby-cvs mailing list