[ruby-cvs:73491] ko1:r66390 (trunk): rename li_table->ar_table (and related names).

ko1 at ruby-lang.org ko1 at ruby-lang.org
Fri Dec 14 10:10:15 JST 2018


ko1	2018-12-14 10:10:15 +0900 (Fri, 14 Dec 2018)

  New Revision: 66390

  https://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=66390

  Log:
    rename li_table->ar_table (and related names).
    
    * internal.h: rename the following names:
      * li_table -> ar_table. "li" means linear (from linear search),
        but we use the word "array" (from data layout).
      * RHASH_ARRAY -> RHASH_AR_TABLE. AR_TABLE is more clear.
      * rb_hash_array_* -> rb_hash_ar_table_*.
      * RHASH_TABLE_P() -> RHASH_ST_TABLE_P(). more clear.
      * RHASH_CLEAR() -> RHASH_ST_CLEAR().
    
    * hash.c: rename "linear_" prefix functions to "ar_" prefix.
    
    * hash.c (linear_init_table): rename to ar_alloc_table.
    
    * debug_counter.h: rename obj_hash_array to obj_hash_ar.

  Modified files:
    trunk/array.c
    trunk/debug_counter.h
    trunk/gc.c
    trunk/hash.c
    trunk/internal.h
    trunk/transient_heap.c


More information about the ruby-cvs mailing list