[ruby-cvs:67817] rhe:r60636 (trunk): openssl: pull test case from upstream commit 62af0446569a

rhe at ruby-lang.org rhe at ruby-lang.org
Sat Nov 4 15:56:16 JST 2017


rhe	2017-11-04 15:56:16 +0900 (Sat, 04 Nov 2017)

  New Revision: 60636

  https://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=60636

  Log:
    openssl: pull test case from upstream commit 62af0446569a
    
    The test case added by r60310 ("fix OpenSSL::SSL::SSLContext#min_version
    doesn't work", 2017-10-21) does not pass with OpenSSL >= 1.1.0 or
    LibreSSL >= 2.6.0. Check that the default 'min_version' value is
    properly enforced by actually attempting a handshake rather than by
    inspecting the SSL option flags.  [ruby-core:83479] [Bug #14039]

  Modified files:
    trunk/test/openssl/test_ssl.rb


More information about the ruby-cvs mailing list