[ruby-cvs:62314] rhe:r55151 (trunk): openssl: rename EC#generate_key to EC#generate_key!

rhe at ruby-lang.org rhe at ruby-lang.org
Wed May 25 01:27:12 JST 2016


rhe	2016-05-25 01:27:11 +0900 (Wed, 25 May 2016)

  New Revision: 55151

  https://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=55151

  Log:
    openssl: rename EC#generate_key to EC#generate_key!
    
    * ext/openssl/ossl_pkey_ec.c (ossl_ec_key_generate_key): Fix up RDoc.
      (Init_ossl_ec): Rename EC#generate_key to EC#generate_key!. Make the
      old name an alias of #generate_key!. This change is for consistency
      with other PKey types.  [ruby-core:45541] [Bug #6567]
    
    * test/openssl/test_pkey_ec.rb: Use EC#generate_key! instead of
      EC#generate_key.

  Modified files:
    trunk/ChangeLog
    trunk/ext/openssl/ossl_pkey_ec.c
    trunk/test/openssl/test_pkey_ec.rb


More information about the ruby-cvs mailing list