[ruby-cvs:62967] ko1:r55803 (trunk): * vm_core.h: rename macros and make them inline functions.

ko1 at ruby-lang.org ko1 at ruby-lang.org
Wed Aug 3 09:28:12 JST 2016


ko1	2016-08-03 09:28:12 +0900 (Wed, 03 Aug 2016)

  New Revision: 55803

  https://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=55803

  Log:
    * vm_core.h: rename macros and make them inline functions.
    
      * rename VM_FRAME_TYPE_FINISH_P() to VM_FRAME_FINISHED_P().
      * rename VM_FRAME_TYPE_BMETHOD_P() to VM_FRAME_BMETHOD_P().

  Modified files:
    trunk/ChangeLog
    trunk/vm.c
    trunk/vm_core.h
    trunk/vm_dump.c
    trunk/vm_insnhelper.c
    trunk/vm_trace.c


More information about the ruby-cvs mailing list