[ruby-cvs:59045] nobu:r51894 (trunk): thread.c: suppress warnings only if GCC6+

nobu at ruby-lang.org nobu at ruby-lang.org
Fri Sep 18 13:43:00 JST 2015


nobu	2015-09-18 13:42:58 +0900 (Fri, 18 Sep 2015)

  New Revision: 51894

  http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=51894

  Log:
    thread.c: suppress warnings only if GCC6+
    
    * thread.c (rb_fd_no_init): suppress warnings by applying ASSUME
      only if GCC 6 or lator, to get rid of freeze with GCC 4.7.2-5.

  Modified files:
    trunk/thread.c


More information about the ruby-cvs mailing list