[ruby-cvs:56726] nobu:r49576 (trunk): openssl: check RAND_edg to support libressl

nobu at ruby-lang.org nobu at ruby-lang.org
Thu Feb 12 18:34:03 JST 2015


nobu	2015-02-12 18:34:02 +0900 (Thu, 12 Feb 2015)

  New Revision: 49576

  http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=49576

  Log:
    openssl: check RAND_edg to support libressl
    
    * ext/openssl/extconf.rb: check RAND_edg to support libressl.
    * ext/openssl/ossl_rand.c (ossl_rand_egd): define only if RAND_edg
      is available.  [Fix GH-829]

  Modified files:
    trunk/ChangeLog
    trunk/ext/openssl/extconf.rb
    trunk/ext/openssl/ossl_rand.c


More information about the ruby-cvs mailing list