[ruby-cvs:57301] nobu:r50152 (trunk): rbconfig.rb: use program version

nobu at ruby-lang.org nobu at ruby-lang.org
Thu Apr 2 16:27:16 JST 2015


nobu	2015-04-02 16:27:12 +0900 (Thu, 02 Apr 2015)

  New Revision: 50152

  http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=50152

  Log:
    rbconfig.rb: use program version
    
    * common.mk, tool/mkconfig.rb: check the running ruby version in
      rbconfig.rb with the program version, as RUBY_VERSION has never
      been affected by --with-ruby-version option.
      [ruby-core:68639] [Bug #11002]
    * configure.in (LIBRUBY_DLDFLAGS): compatibility_version must be
      valid version numbers, not an arbitrary string.

  Modified files:
    trunk/ChangeLog
    trunk/common.mk
    trunk/configure.in
    trunk/tool/mkconfig.rb


More information about the ruby-cvs mailing list