[ruby-cvs:54636] ko1:r47488 (trunk): * gc.c (objspace_total_slot): rename objspace_available_slots.

ko1 at ruby-lang.org ko1 at ruby-lang.org
Wed Sep 10 10:42:09 JST 2014


ko1	2014-09-10 10:42:09 +0900 (Wed, 10 Sep 2014)

  New Revision: 47488

  http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=47488

  Log:
    * gc.c (objspace_total_slot): rename objspace_available_slots.
    * gc.c (objspace_live_slot, objspace_free_slot): rename
      ..._slot() to ..._slots().
    * gc.c (objspace_free_slot): should subtract heap_pages_final_slots.
    * gc.c (gc_stat_internal):
      * add `heap_available_slots' field
      * rename heap_live_slot to heap_live_slots
      * rename heap_free_slot to heap_free_slots
      ref: [Feature #9924]

  Modified files:
    trunk/ChangeLog
    trunk/gc.c


More information about the ruby-cvs mailing list