[ruby-cvs:54951] nobu:r47802 (trunk): digest/*/extconf.rb: do not link openssl when using bundled

nobu at ruby-lang.org nobu at ruby-lang.org
Sun Oct 5 11:03:57 JST 2014


nobu	2014-10-05 11:03:55 +0900 (Sun, 05 Oct 2014)

  New Revision: 47802

  http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=47802

  Log:
    digest/*/extconf.rb: do not link openssl when using bundled
    
    * ext/digest/{md5,rmd160,sha1,sha2}/extconf.rb: configure OpenSSL
      only if bundled libraries is not used, so that OpenSSL is not
      linked unnecessarily.  [ruby-core:65404] [Bug #10324]

  Modified files:
    trunk/ChangeLog
    trunk/ext/digest/md5/extconf.rb
    trunk/ext/digest/rmd160/extconf.rb
    trunk/ext/digest/sha1/extconf.rb
    trunk/ext/digest/sha2/extconf.rb


More information about the ruby-cvs mailing list