[ruby-cvs:55729] nobu:r48580 (trunk): proc.c: use RUBY_SAFE_LEVEL_MAX

nobu at ruby-lang.org nobu at ruby-lang.org
Wed Nov 26 17:01:58 JST 2014


nobu	2014-11-26 17:01:56 +0900 (Wed, 26 Nov 2014)

  New Revision: 48580

  http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=48580

  Log:
    proc.c: use RUBY_SAFE_LEVEL_MAX
    
    * proc.c (rb_method_call_with_block): use RUBY_SAFE_LEVEL_MAX,
      which is declared in include/ruby/ruby.h since 2.1.  The safe
      level is now limited upto 3.

  Modified files:
    trunk/proc.c


More information about the ruby-cvs mailing list