[ruby-cvs:53090] ko1:r45944 (trunk): * ext/openssl/depend: remove dependency from internal headers.

ko1 at ruby-lang.org ko1 at ruby-lang.org
Wed May 14 19:55:40 JST 2014


ko1	2014-05-14 19:55:38 +0900 (Wed, 14 May 2014)

  New Revision: 45944

  http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=rev&revision=45944

  Log:
    * ext/openssl/depend: remove dependency from internal headers.
      [Feature #9612]
    * ext/openssl/ossl.c (ossl_fips_mode_set): ditto.
    * ext/coverage/depend: ditto.
    * include/ruby/thread_native.h: added.
      This header file only provides wrapper functions to control
      native threads. These wrapper functions are used by MRI
      implementation.
    * vm_core.h: use include/ruby/thread_native.h.
    * thread.c: ditto.
    * thread_pthread.h: ditto.
    * thread_win32.h: ditto.
    * thread_native.h: removed.

  Added files:
    trunk/include/ruby/thread_native.h
  Removed files:
    trunk/thread_native.h
  Modified files:
    trunk/ChangeLog
    trunk/ext/coverage/depend
    trunk/ext/openssl/depend
    trunk/ext/openssl/ossl.c
    trunk/thread.c
    trunk/thread_pthread.h
    trunk/thread_win32.h
    trunk/vm_core.h


More information about the ruby-cvs mailing list