[ruby-cvs:53862] ko1:r46716 (trunk): * gc.c: rename is_dead_object() to is_dying_object().

ko1 at ruby-lang.org ko1 at ruby-lang.org
Sun Jul 6 21:03:10 JST 2014


ko1	2014-07-06 21:02:57 +0900 (Sun, 06 Jul 2014)

  New Revision: 46716

  http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=revision&revision=46716

  Log:
    * gc.c: rename is_dead_object() to is_dying_object().
      This function is not opposite against is_live_object()
      because is_dying_object() does *not* check object type.
    * gc.c (is_dying_object): change condition.
    * gc.c (is_live_object): use T_NONE instead of 0.
    * gc.c (rb_objspace_dying_object_p): added.

  Modified files:
    trunk/ChangeLog
    trunk/gc.c


More information about the ruby-cvs mailing list