[ruby-cvs:50185] ko1:r43043 (trunk): * include/ruby/ruby.h: rename RARRAY_RAWPTR() to RARRAY_CONST_PTR().

ko1 at ruby-lang.org ko1 at ruby-lang.org
Wed Sep 25 17:24:36 JST 2013


ko1	2013-09-25 17:24:34 +0900 (Wed, 25 Sep 2013)

  New Revision: 43043

  http://svn.ruby-lang.org/cgi-bin/viewvc.cgi?view=rev&revision=43043

  Log:
    * include/ruby/ruby.h: rename RARRAY_RAWPTR() to RARRAY_CONST_PTR().
      RARRAY_RAWPTR(ary) returns (const VALUE *) type pointer and
      usecase of this macro is not acquire raw pointer, but acquire
      read-only pointer. So we rename to better name.
      RSTRUCT_RAWPTR() is also renamed to RSTRUCT_CONST_PTR()
      (I expect that nobody use it).
    * array.c, compile.c, cont.c, enumerator.c, gc.c, proc.c, random.c,
      string.c, struct.c, thread.c, vm_eval.c, vm_insnhelper.c:
      catch up this change.

  Modified files:
    trunk/ChangeLog
    trunk/array.c
    trunk/compile.c
    trunk/cont.c
    trunk/enumerator.c
    trunk/gc.c
    trunk/include/ruby/ruby.h
    trunk/proc.c
    trunk/random.c
    trunk/string.c
    trunk/struct.c
    trunk/thread.c
    trunk/vm_eval.c
    trunk/vm_insnhelper.c


More information about the ruby-cvs mailing list