[jruby] Hmm. rvm issues installing jruby-9.0.0.0

Eric Christopherson echristopherson at gmail.com
Sat Jul 25 02:24:28 JST 2015


On Thu, Jul 23, 2015 at 11:14 PM, Kimberley Scott
<kimberley.r.scott at mac.com> wrote:
> Hiya,
>
> Having an odd issue on OS-X.
>
> I tried to "rvm install jruby-9.0.0.0" and it said there was already a
> cached version "ruby-9.0.0.0-pre1".
>
> Ok I thought, so I did "rvm list" and uninstalled all the previous jrubies.
>
> Then removed any reference to jruby from "~/.rvm/archives".
>
> Then "rvm get stable".
>
> Then "rvm install jruby-9.0.0.0" again.
>
> To my chagrin, it did this:
>
> --- snip ---
> Searching for binary rubies, this might take some time.
> Found remote file
> https://s3.amazonaws.com/jruby.org/downloads/9.0.0.0.pre1/jruby-bin-9.0.0.0.pre1.tar.gz
> ...compilation elided...
> --- snip ---
>
> Guessing that there may actually be a release version on s3, I wget'd
> "https://s3.amazonaws.com/jruby.org/downloads/9.0.0.0/jruby-bin-9.0.0.0.tar.gz"
> Luckily that worked and I copied the file to "~/.rvm/archives".
> I uninstalled and removed the other "pre1" version and tried again.
>
> But no.
> Despite having jruby-bin-9.0.0.0.tar.gz in the archives folder, rvm insists
> on downloading the pre1 version.
>
> Somewhat at a loss as to what to try next.
> Ideas?

I ran into this too; the reason is that RVM's stable branch still only
has pre1. Additionally, RVM has some files that keep track of archive
SHA sums, and if you don't add your downloaded tarball's SHA to those
files, it just ignores it.

`rvm get head` will enable you to get 9000. I've been bitten in the
past by RVM HEAD, but I decided to just be courageous and try it
again.


-- 
        Eric Christopherson


More information about the JRuby mailing list